Latest News

On and offshore news from EVINRUDE

  • 10/06/2014

    BRP TO SUPPLY EVINRUDE ENGINES TOA NORTH AMERICAN LEADER IN WELDED HEAVY-GAUGE ALUMINUMBOATS

    More
  • 14/05/2014

    BRP WINS 2014 WISCONSIN BUSINESS FRIEND OF THE ENVIRONMENT AWARD

    Emissions sampling equipment supports alternative fuel research

    More
  • 28/04/2014

    NATIONAL WALLEYE TOUR OPENS WITH BIG EVINRUDE WINS

    Team Evinrude’s Dan Stier bags 84.67 pounds of walleye and a tour-opening win on the Cabela’s NWT in Trenton, MI last weekend

    More

E-Nation

Latest Discussions

Join conversations with E-NATION members who share your passion for Evinrude, fishing, boating and all things on the water. Ask questions, give advice and swap stories when you join the Evinrude community.

  • Tigerfish / Mate

    115 E-Tec 2010 won't start

    I went out last weekend for a fishing trip and turned off the motor while stowing all the gear to head home.  I turned the key to start it back up and nothing happened.  I checked the kill switch and made sure I was in Neutral.  Listening closely I heard a high-pitched whine.  The starter was too hot to touch. After waiting 30 minutes or so for it to cool down, I tried again.  Nothing but the whine.  I tapped on the starter with a screwdriver, suspecting the bendix.  No good.  I then put the screwdriver into the flywheel gear to see if it would budge.  I tried the key again and it fired right up.  I figured the bedix was hung up somehow. Back at the house it wouldn't start again.  I checked and have good battery voltage.  I checked the 2 wire plug going to the solenoid and get 12 volts when I turn the key, but don't get anything on the downstream side of the solenoid. Is there anything that will prevent starting that I don't know about before I replace the solenoid?  Also with wierd timing the trim/tilt on the helm now only works in the UP direction.  Works fine both ways at the outboard motor housing. Kerry

    Owner's Zone yesterday 1 post

    Read More
  • Steele-23 / Mate

    2006 250 etec

    Very disappointed in my E-tec with 450 hrs. I've replaced 2 injectors and an emm unit and not sure if I will ever buy another. I own a 1989 evinruid with a zillion hrs on it never an issue and now this. Has anybody experienced this with theirs?

    Owner's Zone yesterday 1 post

    Read More